Infrastructure issues causing connection timeouts
Incident Report for Parsec
Resolved
The networking issues have been resolved.
Posted Nov 20, 2020 - 00:45 EST
Monitoring
The networking issues have subsided at AWS and we're seeing a promising reduction in Parsec connection errors. We will continue to monitor the issue.
Posted Nov 20, 2020 - 00:32 EST
Update
We are continuing to investigate this issue.
Posted Nov 20, 2020 - 00:21 EST
Update
We've confirmed that the timeouts are due to widespread networking issues at our infrastructure provider, Amazon Web Services. We'll continue to monitor and investigate solutions for mitigating these connection timeouts.
Posted Nov 20, 2020 - 00:16 EST
Investigating
We are currently investigating an increase in networking errors within our server infrastructure. Users may experience slowness and difficulty connecting to hosts with the Parsec app.
Posted Nov 20, 2020 - 00:08 EST
This incident affected: API and Signaling Service.